[Résolu] Ciné Digital Manager (Linux 64bits) sous Ubuntu 18.04

regisk

Auteur du sujet
Messages : 29
Enregistré le : jeu. 10 mai 2012 - 20:59
Localisation : Bas-Rhin, Alsace

[Résolu] Ciné Digital Manager (Linux 64bits) sous Ubuntu 18.04

Message » ven. 4 janv. 2019 - 19:59

Bonjour à tous,

Certains d'entre vous ont-ils réussi à installer le client "TMS CinéDigital Manager® VERSION LITE" (Linux 64 bits) sous Ubuntu 18.04 ?
A priori, l'install de la base de données se passe bien, mais pas celle du client.
En install mode console, j'ai tout un tas de pb de dépendances (Ex : plugin-browser-vlc, sox, ...) que je n'arrive pas à résoudre avec un "sudo apt-get -f install", même si certaines dépendances sont bien résolues au passage.

Fun fact : j'ai essayé d'installer la version 32 bits, et là, l'install va jusqu'au bout, CDM apparaît dans la liste des applis installées, mais ne démarre pas (il n'arrive pas à démarrer car java 64 bits installé)

Merci de m'avoir lu.
Modifié en dernier par regisk le mar. 8 janv. 2019 - 18:05, modifié 1 fois.

Coeur Noir

Avatar du membre
Messages : 3668
Enregistré le : lun. 2 mars 2009 - 10:16
Localisation : Maine et Loire - France
Contact :

Message » ven. 4 janv. 2019 - 23:57

Attention, le support 32 bits est déjà plutôt abandonné sous Ubuntu 18.04, sauf quelques variantes ( Xubuntu, Mate, à vérifier ). Et il me semble qu'il n'y aura plus de 32 bits dès la 19.04…

Cela dit un système 64 bits sait utiliser des appli's en 32 ( la réciproque est impossible ).

1) Peux-tu poster ici la liste des dépendances manquantes ou problématiques ?
2) TMS CinéDigital Manager® est-il annoncé compatible avec la version 18.04 d'Ubuntu ?
2,5) s'agit-il d'un paquet .deb, une archive tar.gz, un script ?
3) si c'est juste un jre 32 qui manque, tester en installant default-jre:i386 default-jre-headless:i386 icedtea-plugin voire aussi openjdk-11-jre:i386 et openjdk-11-jdk-headless:i386

regisk

Auteur du sujet
Messages : 29
Enregistré le : jeu. 10 mai 2012 - 20:59
Localisation : Bas-Rhin, Alsace

Message » sam. 5 janv. 2019 - 17:30

Bonjour,

Alors, lorsque je récupère TMS Ciné Digital Manager, Version Lite à partir du site officiel http://www.cinedigitalmanager.com/cdm/telechargements/
Je récupère une archive tar.gz qui une fois décompressée me donne :
Image

De là, le Readme me dit :
Ces packages sont des paquets Debian standards.

Ces packages ont une dépendance avec Java JRE (version 7 ou supérieure). Le processus d'installation peut donc vous inviter à l'installer s'il ne l'est pas déjà. Dans ce cas, une connexion Internet est nécessaire.

Pour installer le TMS Ciné Digital Manager, double-cliquez sur cinedigitalmanagerdatabase_1.2.09_all.deb et installez-le. Ensuite, double-cliquez sur cinedigitalmanager-x64_2.4.25_all.deb et installez-le.

Vous pouvez également installer le TMS Ciné Digital Manager en ligne de commande. Pour cela, ouvrez un terminal et allez dans le répertoire où les fichiers ont été extraits. Ensuite, lancez :
sudo dpkg -i cinedigitalmanagerdatabase_1.2.09_all.deb cinedigitalmanager-x64_2.4.25_all.deb


Dans tous les cas, vous devrez :
1)exécuter la commande :
sudo cp /usr/share/CineDigitalManager/config.properties.new /usr/share/CineDigitalManager/config.properties
2)redémarrer le PC pour terminer l'installation.


J'ai donc fait pour démarrer :

Code : Tout sélectionner

sudo dpkg -i cinedigitalmanagerdatabase_1.2.09_all.deb


qui me retourne :
Préparation du dépaquetage de cinedigitalmanagerdatabase_1.2.09_all.deb ...
java: aucun processus trouvé
Dépaquetage de cinedigitalmanagerdatabase (1.2.09) ...
Paramétrage de cinedigitalmanagerdatabase (1.2.09) ...


Puis :

Code : Tout sélectionner

sudo dpkg -i cinedigitalmanager-x64_2.4.25_all.deb


Qui me retourne :
Sélection du paquet cinedigitalmanager-x64 précédemment désélectionné.
(Lecture de la base de données... 179406 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de cinedigitalmanager-x64_2.4.25_all.deb ...
Dépaquetage de cinedigitalmanager-x64 (2.4.25) ...
dpkg: des problèmes de dépendances empêchent la configuration de cinedigitalmanager-x64 :
cinedigitalmanager-x64 dépend de libwebkitgtk-1.0-0 ; cependant :
Le paquet libwebkitgtk-1.0-0 n'est pas installé.
cinedigitalmanager-x64 dépend de sox ; cependant :
Le paquet sox n'est pas installé.
cinedigitalmanager-x64 dépend de openjpeg-tools ; cependant :
Le paquet openjpeg-tools n'est pas installé.
cinedigitalmanager-x64 dépend de x11vnc ; cependant :
Le paquet x11vnc n'est pas installé.

dpkg: erreur de traitement du paquet cinedigitalmanager-x64 (--install) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour systemd (237-3ubuntu10.9) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-11ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
cinedigitalmanager-x64


Suite à cela, pour installer les paquets absents, je tente :

Code : Tout sélectionner

sudo apt-get -f install


Mais :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
browser-plugin-vlc
Veuillez utiliser « sudo apt autoremove » pour le supprimer.
Les paquets suivants seront ENLEVÉS :
cinedigitalmanager-x64
0 mis à jour, 0 nouvellement installés, 1 à enlever et 4 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 54,8 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n]

Coeur Noir

Avatar du membre
Messages : 3668
Enregistré le : lun. 2 mars 2009 - 10:16
Localisation : Maine et Loire - France
Contact :

Message » sam. 5 janv. 2019 - 20:45

Commence d'abord par installer les paquets « manquants » ensuite ré-installe les packages .deb de CDS.

Code : Tout sélectionner

sudo apt install libwebkitgtk-1.0-0 sox openjpeg-tools x11vnc

Apparemment openjpeg-tools n'est pas dans les dépôts de la 18.04 ( ? ) tu pourras télécharger son .deb directement là : https://packages.ubuntu.com/xenial/openjpeg-tools ( il était présent sous 16.04 ou 14.04 ).
Tu peux utiliser un gestionnaire de paquets « graphiques » tel que synaptic.
Pour installer des paquets .deb il y a aussi gdebi ( qui résoudra les dépendances, contrairement à dpkg )

Si après cela ça coince encore :

Code : Tout sélectionner

sudo dpkg --configure -a
sudo apt update
sudo apt full-upgrade
sudo apt autoremove --purge


edit : sous 18.04 openjpeg-tools semble avoir été remplacé par libopenjp2-tools présent dans les dépôts.

regisk

Auteur du sujet
Messages : 29
Enregistré le : jeu. 10 mai 2012 - 20:59
Localisation : Bas-Rhin, Alsace

Message » lun. 7 janv. 2019 - 22:07

Merci pour ta réponse,

Quand je lance la première commande pour installer les paquets manquants, il me répond :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet openjpeg-tools n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
E: Le paquet « openjpeg-tools » n'a pas de version susceptible d'être installée

Coeur Noir

Avatar du membre
Messages : 3668
Enregistré le : lun. 2 mars 2009 - 10:16
Localisation : Maine et Loire - France
Contact :

Message » lun. 7 janv. 2019 - 22:15

Oui je te l'avais signalé : je t'invite à relire le post du 5 janvier 20:45 ;-)

Pour openjpeg-tools soit tu installes manuellement celui dispo pour la 16.04 ( ça devrait passer ) soit tu installes libopenjp2-tools ( moins sûr que ça marche ).

Ou encore une autre solution : tu installes Ubuntu 16.04 ( LTS, maintenue jusqu'en 2021 ) plutôt que 18.04.

regisk

Auteur du sujet
Messages : 29
Enregistré le : jeu. 10 mai 2012 - 20:59
Localisation : Bas-Rhin, Alsace

Message » mar. 8 janv. 2019 - 17:20

Merci Coeur Noir,
Ça marche.
C'est surtout gdebi qui m'a aidé à résoudre les problèmes de dépendances, au final.
A bientôt !

Coeur Noir

Avatar du membre
Messages : 3668
Enregistré le : lun. 2 mars 2009 - 10:16
Localisation : Maine et Loire - France
Contact :

Message » mar. 8 janv. 2019 - 20:32

Et donc tu as installé openjpeg-tools ou libopenjp2-tools ?
Quoi qu'il en soit l'absence - ou la non correspondance - concernant ce paquet ne devrait pas t'empêcher d'utiliser le TMS ( il me semble que ça a à voir avec la créa de DCP et pour ça, il vaut mieux utiliser dcp-o-matic ).
regisk a écrit :C'est surtout gdebi qui m'a aidé à résoudre les problèmes de dépendances, au final.

Là ce qui serait bien c'est que tu donnes la liste de ce qu'il a installé, histoire que d'autres puissent en profiter ;-) sionon je suis prêt à parier qu'il s'agit de ceux que je te proposais d'installer…
Ça me paraîtrait judicieux aussi de signaler à CDS que leur logiciel réclame une dépendance qui n'existe plus sous la 18.04 LTS d'Ubuntu ( openjpeg-tools ). Puisque ça m'étonnerait fort que Canonical - l'éditeur d'Ubuntu - revienne sur ce changement, CDS pourrait peut-être inclure d'office la ou les librairie⋅s en question ? Ou fournir leur app' en format Snap ?
N'étant plus « client » de CDS pour l'instant je me vois mal leur signaler ça…
Modifié en dernier par Coeur Noir le mar. 8 janv. 2019 - 20:45, modifié 1 fois.

regisk

Auteur du sujet
Messages : 29
Enregistré le : jeu. 10 mai 2012 - 20:59
Localisation : Bas-Rhin, Alsace

Message » mar. 8 janv. 2019 - 20:43

Oui, openjpeg-tools.
Et lui-même avait une autre dépendance à résoudre au préalable, que gdebi m'a indiqué de façon explicite.
Sans cela, l'installation refusait d'aller jusqu'au bout.
Si tu as de bonnes lectures sur la notion de dépendances Linux à me conseiller, je suis preneur, car je ne suis pas encore certain d'avoir compris toute la logique sous-jacente.

Coeur Noir

Avatar du membre
Messages : 3668
Enregistré le : lun. 2 mars 2009 - 10:16
Localisation : Maine et Loire - France
Contact :

Message » mar. 8 janv. 2019 - 20:55

openjpeg-tools → ok, mais ça n'est plus dispo sous 18.04 donc qu'a-t-il pu proposer à la place ? ( d'où la modif' de mon message précédent : de mémoire il y a un un créateur de DCP inclus au TMS CDS et à mon avis il ne fonctionnera pas sur ton installation sous 18.04 ce qui n'est pas bien grave puisque dcp-o-matic existe par ailleurs… )

Je t'avais déjà mis quelques liens vers la doc' Ubuntu mais en voici d'autres :
https://doc.ubuntu-fr.org/paquet
https://doc.ubuntu-fr.org/depots
https://doc.ubuntu-fr.org/gestionnaire_de_paquets
https://doc.ubuntu-fr.org/installation_logiciel
https://doc.ubuntu-fr.org/tutoriel/comm ... _un_paquet

Et puis si besoin d'aide concernant Ubuntu : https://forum.ubuntu-fr.org/ je « sévis » aussi là-bas, sous le même pseudo ;-)